Solving “Security error accessing url” in FLEX

Hi.

During the developing process of my improved widget for Flex viewer I start getting a weird error accessing a RSS feed .

After a couple of hours trying to figure out what the problem was a got the solution.

When the Flash Player try to access a resource in a server, it first look for a file called crossdomain.xml which has the security policies for the site we are accessing.

In order to solve the problem, I got into my wordpress blog and added a crossdomain.xml which content is as follow:

[sourcecode language=”xml”]

<?xml version="1.0"?>

<cross-domain-policy>

<allow-access-from domain="*"/>

</cross-domain-policy>

[/sourcecode]

Comments are closed.